ページの先頭です。
ここから本文です。

よくあるご質問(サポートFAQ)

【StarOffice】 StarOfficeX: ユーザ登録・削除時に、キャビネットへの同期が失敗します

質問内容

メンテナンスツールでユーザの登録・削除時に、以下のダイアログメッセージが表示されます。

ダイアログメッセージ:
<StarOfficeフォルダ>\BusinessDirectory\bin\sobdsync.exeでエラーが発生しました。

メンテナンスツールの下部の領域を確認すると下記のメッセージがありました。

メッセージ:
連携処理でエラーが発生しました。
キャビネット()の同期が完了していません。
hh:mm:ss 同期化プログラム()で異常終了しました。エラーコード:-1

対処方法を教えてください。


回答内容

【原因】
このエラーメッセージはメールサーバへの同期失敗時に表示される場合があります。
ユーザの登録・削除時に同期に失敗する原因は複数考えられますが、原因の一つとして、キャビネットサーバで使用しているデータベース(PERCIO)で、処理競合が発生している可能性が考えられます。

エンドユーザによるキャビネット/掲示板へのアクセス、運用コマンドによるキャビネットサーバへのアクセス、ウィルススキャンによるキャビネットへのアクセスがあって、アクセスが集中している時同期しようとすると、エラーが発生する場合があります。

メンテナンスツールによる登録・削除だけでなく、somnt.batによる登録・削除時も、同様のエラーが発生する場合があります。


【対処方法】
エラーが発生した場合は、再度同期処理を実行してください。(または、後述のマニュアル箇所に記載のsomnt.batの実行に失敗した場合の対処を行ってください。)

somnt.batコマンドの実行に失敗した場合の対処方法については、下記マニュアルに記載されています。(メンテナンスツールで失敗した場合も同様の対処が必要です。)

StarOffice X ~運用管理者編~ 利用者環境構築・運用ガイド
  付録B 運用バッチツールsomnt.batの実行に失敗した場合
※StarOfficeのバージョンによって付録の番号が異なる場合があります。

<回避策>
ユーザを多数登録する場合等は、一般利用者の少ない夜間等に実施することを推奨いたします。


●PERCIOの競合エラーに関する参考情報

負荷集中でエラーが発生した場合、キャビネットサーバのログに以下のエラーコードを含むエラーが記録されている可能性があります。

  エラーコード:
      0x4088050e (セッション数不足)
      0x40280a07 (処理競合)
      0x40280a08 (処理競合)

    該当ファイル:
      <StarOfficeフォルダ>\Cabinet\Server\Log
      ・sbxc_om.log
      ・omservice.log

エラーコードの内容については以下のマニュアルをご参照ください。

StarOffice X ~運用管理者編~ リファレンスガイド
  - 第 1 章 キャビネット・掲示板
    - エラーメッセージ一覧
※StarOfficeのバージョンによって章番号が異なる場合があります。


対象バージョンは以下の通りです。
 - StarOffice X V1.0以降のバージョン
 

製品名カテゴリ

StarOffice X

関連情報

  • コンテンツID: 3150109182
  • 公開日: 2014年12月26日
  • 最終更新日:2015年06月29日

アンケート

サポート情報充実のためアンケートにご協力をお願いいたします。



コメント欄:
ここからページ共通メニューです。 ページ共通メニューを読み飛ばす。