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よくあるご質問(サポートFAQ)

【StarOffice】 StarOfficeX: SO-X BizDirSync Serviceサービスが起動しません。

質問内容

サービス「SO-X BizDirSync Service」を起動しようとすると、以下のダイアログメッセージが表示され、サービスを起動できません。

ダイアログメッセージ:
ローカル コンピューター 上の SO-X BizDirSync Service サービスは起動して停止しました。サービスの中には、ほかのサービスやプログラムで使用されていない場合は自動的に停止するものがあります。

このエラーが出力される原因と対処方法を教えてください。


回答内容


【原因】
ディレクトリマスタサーバに以下のファイルが存在していない可能性があります。

<StarOfficeフォルダ>\BusinessDirectory\bin\commandrule\PLUGINRULE_05MAIL

また、PLUGINRULE_05MAILが存在していないことによりSO-X BizDirSync Serviceが起動できない場合は以下のログファイルに「No Command Rule」と記録されるため、ログファイルから確認することができます。

ログファイル:
<StarOfficeフォルダ>\BusinessDirectory\log\YYYYMMDD.log (YYYYMMDDは年月日)

ログ出力内容例:
09:55:40 [5876] F4393: No Command Rule

【対処方法】
StarOffice Xインストール直後には上記ファイルが存在しています。
インストール後に削除したか、または名前を変更したと思われますので、元に戻してください。

【メール機能を使用しない運用の場合について】
メール機能を使用しないという理由で意図的に PLUGINRULE_05MAIL ファイルを削除している環境の場合は、"SO-X BizDirSync Service"は不要なサービスですので、起動しないでください。自動起動する設定になっている場合は、手動か無効にしてください。
なお、メール機能を使用しない場合、ディレクトリマスタサーバの下記フォルダにメールサーバへの連携用のファイルが、ユーザがパスワードを変更するたびに生成され続けてしまいますので、定期的に下記フォルダ配下のファイルを削除する必要があります。
 <StarOfficeフォルダ>\BusinessDirectory\bin\plugout\
上記フォルダ配下のファイルを自動的に削除したい場合は、下記の設定ファイルに上記plugoutフォルダを書き加えることで、タスクスケジューラのタスク「SO-X BizDir so_edgarbage」によって自動的に定期削除できます。
 <StarOfficeフォルダ>\BusinessDirectory\bin\garbage\edgarbage.conf

【補足説明】
「SO-X BizDirSync Service」サービスは、ユーザのパスワード変更時に、メールサーバに自動的に連携し、パスワードを同期するためのサービスです。


対象バージョンは以下の通りです。
 - StarOffice X V1.0以降のバージョン
 

製品名カテゴリ

StarOffice X

  • コンテンツID: 3150109184
  • 公開日: 2014年12月26日
  • 最終更新日:2015年06月24日

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