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よくあるご質問(サポートFAQ)

【StarOffice】 StarOfficeX: Windows Server 2016で、SO-X FTS Serverサービスが起動せず、キャビネットと掲示板で検索ができない

質問内容

キャビネットや掲示板の検索利用時に、以下のエラーダイアログメッセージが表示され検索が実施できません。
    検索ブローカもしくは検索サーバへの接続が拒否されました。 (code=0x2f000066)

OS 起動後にSO-X FTS Serverサービスが起動しておらず、SO-X FTS Serverサービスを手動で再起動しても、下記エラーダイアログメッセージが表示され停止します。
    SO-X FTS Serverは起動して停止しました。サービスの中には、ほかのサービスやプログラムで使用していない場合は自動的に停止するものがあります。

原因と対処方法を教えてください。

回答内容

【現象】
サーバマシンが Windows Server 2016 の環境において、キャビネットサービス画面、掲示板サービス画面で検索操作をおこなうと以下のエラーダイアログメッセージが表示され、サーバマシンを再起動するまで検索できない問題が発生する場合があります。
    検索ブローカもしくは検索サーバへの接続が拒否されました。 (code=0x2f000066)

  [発生条件] お客様の運用環境が以下の全ての条件に合致する場合に発生する場合があります。
    ・製品バージョンが StarOffice X V5.2 または V5.3
    ・サーバOSが Windows Server 2016
      (Windows Server 2019 ではエラーは発生しません)
    ・OS起動直後のサービス起動時
      (本事象はOS起動時に発生していなければ、運用中に発生することはありません)

  [問題発生時の確認内容]
    オールインワンサーバ、または、マルチサーバ構成の場合のリソースサーバ(検索サーバ)で以下を確認し、両方に合致する場合は本問題が発生しています。
      (A) 検索サーバのログファイル確認
            事象発生時には以下の記録が残ります。
              ログファイル:<StarOfficeフォルダ>\Search\FTSSearchServer\log\FTSDSServerService.log
              記録内容(例):
                I 2022/08/14 08:26:39 00002E84 Failed to initialize service
                I 2022/08/14 08:26:39 00002E84 プロセスの生成に失敗しました。
                E 2022/08/14 08:26:39 00002E84 Error:  BCSService::ThreadMain(0x2f000056) サービスの初期化に失敗しました。  (Line=761)
      (B) 検索サーバサービスの手動起動確認
            サーバのコマンドプロンプトで以下を実行することで、本事象が発生しているかを確認できます。
                FTSDSServer.exe "SOXFTSServer" 0
            事象発生時には、次のメッセージが表示されます。
              -------------------------------------------------------
              Error occurred during initialization of VM
              Could not reserve enough space for 524288KB object heap
              -------------------------------------------------------

  [類似事象]
    SO-X FTS Serverサービスを手動で再起動できる場合は、別の問題の可能性があります。
    関連情報の「キャビネット検索でエラーコード0x2f000066」をご参照願います。

【原因】
検索サーバがインストールされているサーバマシンを再起動した際に、検索サーバサービス (SO-X FTS Server) 及びWindowsのdllはWindows Server 2016 の機能により Windows のメモリ領域に配置されます。
Windowsのdllは通常はメモリ領域の後半付近に配置されますが、低い頻度でメモリ領域の中間部分に配置される場合があります。
Windowsのdllがメモリ領域の中間部分に配置された場合、検索サーバサービスの起動時に利用できるメモリ量が少なくなり、メモリ不足が発生することで検索サーバサービスの起動が失敗します。
また、Windowsのdllのメモリ領域への配置は OS の起動時に決定されるため、以降の検索サーバサービスの起動は必ず失敗し、OS を再起動するまで検索サーバサービスは起動できません。

このメモリ領域への配置については Microsoft 社より下記2点が提示されており、Windows Server 2016 での動作を変更することはできません。
    ・Windows Server 2016 の仕様である
    ・Windows Server 2019 では仕様を変更しており、同じ問題は発生しない

【緊急対処】
本事象に対する事前の回避策はございません。
問題が発生した場合は、以下のサーバマシンを再起動してください。
    ・オールインワンサーバ、または、マルチサーバ構成の場合のリソースサーバ(検索サーバ)
但し、マルチサーバ構成の場合、再起動対象のサーバがRDBサーバの役割を持つ場合は、Webサーバと横断検索サーバの再起動も必要です。
キャビネット機能を持つリソースサーバ(検索サーバ)の再起動中は、一時的にキャビネットアクセスに失敗します。
Webサーバの再起動は、そのサーバでは一時的にStarOffice Xが利用できない、またセッションが切れる影響がありますので、運用時間帯外等に行ってください。

【本対処】
サーバマシンの起動時に本問題が発生したことを検知する仕組み、および、自動再起動を選択可能とするツールを2022年10月末に公開しました。
必要に応じて適用のご検討をお願いします。
詳細は関連情報の以下を参照ください。
 ・SO-X FTS Serverサービス 起動状況検知ツール 物件
 ・SO-X FTS Serverサービス 起動状況検知ツール リリースメモ


対象バージョンは以下の通りです。
 - StarOffice X V5.2 および V5.3

製品名カテゴリ

StarOffice X

関連情報

  • コンテンツID: 3150116222
  • 公開日: 2022年09月07日
  • 最終更新日:2022年11月01日

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